VLAN


Switch üzerindeki tüm portların anlık bir özeti nasıl görüntülenir?

enable mode’a girildikten sonra;

show ip interface brief ile switch üzerindeki portların anlık bir özeti görüntülenebilir.


 VLAN’in sağladığı avantajlar nelerdir?

VLAN, LAN kavramını sanallaştırarak fiziksel sınırlamalardan kurtarır. Ağ trafiğini segmentler ve izole ederek güvenliği arttırır.


VLAN öncesi çözümler nelerdir? 

Ayrıştırılma gerektiren noktalara router yerleştirilerek bloklama. Her Segment’e Bir Server.


VLAN’lar arası geçiş için eski, fakat geçerli ihtimal nedir? ROAS nedir?

Her VLAN’i bir router’ın bir interface’ine bağlamak eski fakat geçerli bir ihtimaldir. Kablolama maliyetine sebep verir. ROAS benzer bir şekilde subinterface’ler yapılarak vlan’lar arası geçiş için kullanılır.


Cloud ve L3 Switching’in vlan’ler ile olan ilişkisi nedir?

L3 switching, switching ve routing’in en iyi özelliklerini tek bir cihazda birleştirir. ASIC kullanılmasına rağmen yavaşdır ve tüm fonksiyonları desteklemez. VLAN’lar arası routing yapmamak da bir ihtimaldir. Cloud çözümler VLAN’ları internete bağlayarak bu ihtimali destekler.


DTP açılımı nedir? Ne amaçla kullanılır? Tehlikesi nedir?

Dynamic Trunking Protocol, Portların access mi trunk mu olacağını otomatik olarak belirlemek için kullanılır.


802.1Q protokolü nedir? Ne amaçla kullanılır?

Switchler arası tagleme işlemi 802.1Q protokolü ile yapılır. Bu protokolün en önemli güzelliği endüstri standardı olmasıdır. Farklı cihazların  (VMware Server, Cisco Switch, Grandstream Cisco -olmayan bir IP telefon, HP Switch) hepsi bu standart protokolü kullandığından bütün bu farklı cihazlara taglanan trafik yollanabilir.


native-vlan ne için kullanılır?

Trunk portlar etiketli (tagged) trafiği gönderip alırlar. Peki trafik tagsiz olursa ne olur? Native VLAN trunk portlara gönderilen etiketsiz trafiği göndermek için kullanılır. Örneğin switchport trunk native vlan 6 dersek vlan tag’i olmadan gönderilen trafik vlan 5’de yer alacaktır.


VTP nin açılımı nedir? Ne amaçla kullanılır? Tehlikesi nedir?

VLAN trunking protocol yanlış isimlendirilmiş bir protokoldür. İsmine rağmen trunking protocol değildir. Cisco tarafından Cisco cihazlarda kullanılmak için geliştirilmiştir. VLAN’lar arası replikasyonu gerçekleştirmek için kullanılır. VTP trunk linkler üzerinden çalışır. Fakat bir trunking protokol değildir.

Yalnızca iki trunking protokol vardır. ISL ve 802.1Q Kullanılan ise yalnızca 802.1Q’dur.


Bir port hangi modlarda bulunabilir? Hangi modlar kullanılmamalıdır neden?

trunk, access, nonegotiate, dynamic auto, dynamic desirable


Switch’de VLAN nasıl oluşturulur?

enable mode’a, configuration mode’a girildikten sonra;

vlan vlan-numarası komutu ile vlan oluşturulur.


Switch’de VLAN’a nasıl isim verilir?

enable mode’a, configuration mode’a ve ardından vlan vlan-numarası ile ilgili vlan’a girildikten sonra;

name verilecek-isim komutu ile vlan’a isim verilir.


STP nedir? Amacı nedir?  Ne amaçla kapatılır?

STP Spanning tree protocol anlamına gelir. STP, collision-domain’de tek bir aktif bağlantı kalması için bazı portları bloklar. Döngüleri engeller.

Normalde portların aktif hale gelmeleri 30 saniye alır. STP kapatılarak portların anında aktif hale gelmeleri sağlanır.


Portlarda STP nasıl inaktif hale getirilir?

enable mode’a, configuration mode’a ve ardından interface interface-adi ile ilgili port’un interface’ine gidildikten sonra;

spanning-tree portfast komutu ile STP inaktif hale getirilir.


Switch’de bir port nasıl bir vlan’a atanır?

enable mode’a, configuration mode’a ve ardından interface interface-adi ile ilgili port’un interface’ine gidildikten sonra;

switchport mode access ile port access moduna geçirilir.

switchport access vlan vlan-numarasi komutu ile port vlan’a atanır.


vlan.dat dosyası nasıl silinir?

enable mode’a girildikten sonra;

delete flash vlan.dat ile vlan.dat dosyası silinir.


Switch üzerinde VTP durumu nasıl görüntülenir?

enable mode’a girildikten sonra;

show vtp status ile vtp durumu görüntülenir.


Switch üzerinde VTP yapılandırması nasıl yapılır?

enable mode’a, configuration mode’a girildikten sonra;

vtp mode server ile vtp server moduna geçirilir.

vtp domain mydomain ile domain ismi verilir.

vtp password mypass123 ile parola verilir.


Switch’de bir port nasıl trunk mode’a alınır?

enable mode’a, configuration mode’a ve ardından interface interface-adi ile ilgili port’un interface’ine gidildikten sonra;

switchport trunk encapsulation dot1q ile trunking protokol belirtilir. (Yeni switchlerde ISL kullanılmadığından lazım değildir.)

switchport mode trunk ile port trunk moduna geçirilir.


Switch’de bir portun VLAN ve trunking bilgileri nasıl görüntülenir?

enable mode’a girildikten sonra;

show interfaces interface-adi switchport ile portun VLAN bilgileri görüntülenebilir.


Switch üzerindeki bir portun detaylı bilgisi (interface sayaçları) görüntülenir?

enable mode’a girildikten sonra;

show ip interfaces interface-adi ile switch üzerindeki portların detaylı bilgisi (interface sayaçları) görüntülenebilir.


Switch portu üzerinde interface counter’ları sıfırlayan komut nedir?

clear counters interface-adi


Switch portu üzerindeki dupleks ayarı nereden görüntülenir?

enable mode’a girildikten sonra;

show interfaces fa0/10


Switch portu üzerindeki collusionlar nasıl görüntülenir?

enable mode’a girildikten sonra;

show interfaces fa0/10


Switch üzerinde yalnızca bir interface’in yapılandırması nasıl görüntülenir?

enable mode’a girildikten sonra;

show run int fa0/10


Switch trunk portu üzerinde yalnızca bir vlan’a nasıl izin verilir?

enable mode’a, configuration mode’a ve ardından interface interface-adi ile ilgili port’un interface’ine gidildikten sonra;

switchport trunk allowed vlan vlan-no ile yalnızca bir vlan’a izin verilir.


Switch trunk portu üzerinde yeni bir vlan’a nasıl izin verilir?

enable mode’a, configuration mode’a ve ardından interface interface-adi ile ilgili port’un interface’ine gidildikten sonra;

switchport trunk allowed vlan add vlan-no ile yeni bir vlan’a izin verilir?

Routing


Router üzerindeki interface’lerin anlık bir özeti nasıl görüntülenir?


Routerların interface’lerine nasıl ip adresi verilir?


Routerlarda routing tablosu nasıl görüntülenir?


Routerlarda routing tablosunda ne gibi bilgiler yer alır?

Cisco cihazlarda direk bağlı girdilerde route source (nasıl öğrenildiği), destination network ve outgoing interface bilgileri yer alır.

Uzaktaki networklere ait girdilerde bunlara administrative distance (güvenilirlik), metric (kalitesi), next hop ve route timestamp eklenir.


No shutdown komutu routerlarda ne amaçla kullanılır?

Router interface’leri kutudan çıkarıldıklarında inaktiftirler. Aktif hale getirilmeleri için no shutdown komutunun kullanılması gerekmektedir.


Default route nedir?

Dafault route aynı zamanda gateway of the last resort olarak bilinir. Hedef adresi routing tablosundaki hiçbir route ile eşleşmeyen paketleri iletmek için kullanılan route’dur. varsayılan yol için CIDR notasyonu IPv4’te 0.0.0.0/0, IPv6’da :: / 0dır.

Aşağıda 192.168.1.1 ISP CPE router’ının bize bakan bacağıdır.


Static routing nedir?

Router’lara bağlı networkler aralarında bir routing protokolü yoksa konuşamaz. Bunun için ya route‘un ya statik tanımlanması ya da bir routing protocol aracılığıyla tanımlanması gerekmektedir.


Routerlarda static routing yaparak default route nasıl tanımlanır?

ip route 10.5.3.0 255.255.255.0 10.5.2.2

Network tanımı, komşu routerın bize bakan interface’inin IP adresi.


ROAS Nasıl Yapılır?

Router’ switch arası bağlantı switchport mode trunk ile trunk yapılır.

Her bir subinterface girilir. encapsulation dot1Q <vlan-no> ile vlan atanır.

Ardından ip addr <ip-adresi> <subnet-mask> ile IP verilir.